Coast Resorts Open Roads Forum: Class A Motorhomes: Onan 5500 problem
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Onan 5500 problem

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
bobkatmsu

clearwater, fl

Senior Member

Joined: 08/07/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 08:22am Link  |  Quote  |  Print  |  Notify Moderator

Last time I took out my 2007 38' Safari Simba, about a month ago, I was running my generator so I could use the front a/c unit. After about 5 minutes generator stopped running. Was showing a code that it was out of gas. As fuel tank was full, I changed fuel filter. The one I bought was not exactly the same but close. After changing, no problem. Used generator all weekend, as we were dry camping. Yesterday took motorhome out just to get everything working. Generator did the exact same thing. Ran for 5 minutes then shut off. Primed, and restarted. Would run for 30 seconds and shut off.
Open to suggestions.

WyoTraveler

Wyoming

Senior Member

Joined: 11/22/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 08:39am Link  |  Quote  |  Print  |  Notify Moderator

I assume same 36 code. No fuel. My gnerator is new and under warranty. I took it to Onan dealer. They replaced the fuel pump under warranty. Runs OK now. There was another post recently and RVer replaced with an Airtex E11015 fuel pump from Amazon for about half the price of an Onan fuel pump and said it worked fine. Heat is apparently the fuel pump killer. If I have any more problems I am thinking of moving the fuel pump a couple of feet from the generator and mounting it to the MH frame so it will stay cooler. Amazon wants $50.80 for the Airtex and $81.74 for he Onan fuel pump. You need to look at your fuel pump. Mine has a 90 degee bend in the metal line and costs more. About double the cost for exact model.

frankdamp

Anacortes

Senior Member

Joined: 05/04/2005

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 12:50pm Link  |  Quote  |  Print  |  Notify Moderator

I replaced the original Onan pump with an Airtex. I seem to be having high fuel pressure issues now. The generator still won't run for more than a couple of seconds and seems to be running very rich. Needs more investigation yet.

I don't know how Amazon gets the Onan that cheap. I was quoted $118.00 for one. The Airtex looks identical except for the mounting bracket and was $48 at a local auto parts store.


Frank Damp, DW - Eileen, location Anacortes, WA, now retired RVers (since Dec 2014)

Considerations over. Just (07 June 17) adopted an almost 9 year old female yellow Lab.

Big Katuna

Deland, FL

Senior Member

Joined: 12/27/2003

View Profile



Good Sam RV Club Member

Online
Posted: 08/04/13 03:17pm Link  |  Quote  |  Print  |  Notify Moderator

Check the carb nuts. One of mine backed out and when I hit bumps the gen would sometimes shut off.


My Kharma ran over my Dogma.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  All

 > Onan 5500 problem
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2017 CWI, Inc. © 2017 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS