Coast Resorts Open Roads Forum: Generator not sending power inside. PLEASE HELP!!
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > Generator not sending power inside. PLEASE HELP!!

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev
RLS7201

Beautyful Downtown Gladstone, MO

Senior Member

Joined: 10/26/2002

View Profile


Online
Posted: 08/04/13 12:18pm Link  |  Quote  |  Print  |  Notify Moderator

THE-RV-MAN wrote:

Mandalay Parr wrote:

You changed the voltage regulator. Are there settings or adjustments to be made?

Give me the P/N of the regulator. Maybe I can look it up.
I am an electrical person.

Jerry


http://www.flightsystems.com/p-ONAN-305.html


I went through 3 Flight Systems voltage regulators, on a customers MH, before I finally give up and spent the bucks for a real Cummins/Onan regulator that worked correctly. They was always willing to replace the faulty regulator but the waste of my time took all the profit out of the job. I'll not deal with them again.

Richard

THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 12:23pm Link  |  Quote  |  Print  |  Notify Moderator

RLS7201 wrote:

THE-RV-MAN wrote:

Mandalay Parr wrote:

You changed the voltage regulator. Are there settings or adjustments to be made?

Give me the P/N of the regulator. Maybe I can look it up.
I am an electrical person.

Jerry


http://www.flightsystems.com/p-ONAN-305.html


I went through 3 Flight Systems voltage regulators, on a customers MH, before I finally give up and spent the bucks for a real Cummins/Onan regulator that worked correctly. They was always willing to replace the faulty regulator but the waste of my time took all the profit out of the job. I'll not deal with them again.

So you are saying it mite not be any good?

Richard



Full Timer....And loving it!!

2003 King Of The Road 5th Wheeler


THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/05/13 06:35pm Link  |  Quote  |  Print  |  Notify Moderator

Now check this out. I took the RV down the shore. Just for fun I asked my wife to turn on the genny and the microwave light went on (the time). But the microwave didn't work when we tried to run it. We cleaned the slip rings I Guess that helped a little.

Mandalay Parr

Phoenix, AZ

Senior Member

Joined: 07/09/2004

View Profile



Good Sam RV Club Member

Offline
Posted: 08/05/13 08:07pm Link  |  Quote  |  Print  |  Notify Moderator

Manual

Did you do the tests in this manual?


Jerry Parr
Full-time
2005 Mandalay 40B
Cat C7 350, 4 Slides
Blue Ox, Brake Buddy
2004 CR-V Toad
[email protected]
602-321-8141
K7OU
Kenwood Radios
ARRL, W5YI, & LARC VE
SKYWARN Weather Spotter

THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/09/13 05:55pm Link  |  Quote  |  Print  |  Notify Moderator

Mandalay Parr wrote:

Manual

Did you do the tests in this manual?


Yes I did. But still nothing.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Prev

Open Roads Forum  >  Class A Motorhomes  >  All

 > Generator not sending power inside. PLEASE HELP!!
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2017 CWI, Inc. © 2017 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS