Coast Resorts Open Roads Forum: HELP!! Generator not turning on AC or microwave
Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > HELP!! Generator not turning on AC or microwave

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev
Kaz

Atlanta, GA, USA

Senior Member

Joined: 04/20/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 04:55am Link  |  Quote  |  Print  |  Notify Moderator

THE-RV-MAN wrote:

Everything works fine on shore power.


How long are you waiting before hitting the AC? I hate to mention the obvious, but it's important to be methodical while you rule out things and try to trace down the problem. In our coach, I've got to wait about 30 seconds after the generator is running before the circuits close on the AC or microwave. (If this is a "duh" kind of suggestion, sorry--go back to the real checklist.)

Skip


Skip
K4EAK
2013 Thor ACE 30.1
http://skiprd.com

THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/04/13 10:27am Link  |  Quote  |  Print  |  Notify Moderator

Kaz wrote:

THE-RV-MAN wrote:

Everything works fine on shore power.


How long are you waiting before hitting the AC? I hate to mention the obvious, but it's important to be methodical while you rule out things and try to trace down the problem. In our coach, I've got to wait about 30 seconds after the generator is running before the circuits close on the AC or microwave. (If this is a "duh" kind of suggestion, sorry--go back to the real checklist.)

Skip


What do you mean close?
I had the genny run for 5 min and still no luck. This is driving me crazy. I just want it to work.


Full Timer....And loving it!!

2003 King Of The Road 5th Wheeler


Cruisemaster1975

Reno

New Member

Joined: 06/27/2013

View Profile


Offline
Posted: 08/04/13 11:02pm Link  |  Quote  |  Print  |  Notify Moderator

pass42 is probable right had similar issues was second breaker on generator

Kaz

Atlanta, GA, USA

Senior Member

Joined: 04/20/2002

View Profile



Good Sam RV Club Member

Offline
Posted: 08/05/13 03:49am Link  |  Quote  |  Print  |  Notify Moderator

THE-RV-MAN wrote:

What do you mean close? I had the genny run for 5 min and still no luck. This is driving me crazy. I just want it to work.


Never mind...just a guess. By "close" I meant that the circuit is open (not complete) until the genset runs for a few moments, and then a relay (or some such thing) closes to complete the circuit. But 5 minutes is way more than enough time. Try the other suggestions.

Skip

bsinmich

Holland, MI

Senior Member

Joined: 11/18/2000

View Profile



Good Sam RV Club Member

Offline
Posted: 08/05/13 05:01am Link  |  Quote  |  Print  |  Notify Moderator

With a Flair he has 30 amp service and no inverter as factory equipment. When you said the generator is putting out 60, is that volts? If that is the case your bulbs should be burning very dim. You should not be trying to run the generator while the RV plug is also plugged into a power outlet. Do you have a transfer switch or do you have to plug the power cord into an outlet on the coach? I would quit just replacing parts until you have a good diagnosis. Most times electrical parts are not returnable. It may be cheaper to take it in for service.


1975 GMC Eleganza II & 1995 Roadtrek Versatile. Both old enough to vote and drink (gas)

THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/05/13 06:33pm Link  |  Quote  |  Print  |  Notify Moderator

bsinmich wrote:

With a Flair he has 30 amp service and no inverter as factory equipment. When you said the generator is putting out 60, is that volts? If that is the case your bulbs should be burning very dim. You should not be trying to run the generator while the RV plug is also plugged into a power outlet. Do you have a transfer switch or do you have to plug the power cord into an outlet on the coach? I would quit just replacing parts until you have a good diagnosis. Most times electrical parts are not returnable. It may be cheaper to take it in for service.


Yes 60volts. Now check this out. I took the RV down the shore. Just for fun I asked my wife to turn on the genny and the microwave light went on (the time). But the microwave didn't work when we tried to run it. We cleaned the slip rings I Guess that helped a little.

oilcan4

New York

New Member

Joined: 03/13/2009

View Profile





Offline
Posted: 08/06/13 07:38pm Link  |  Quote  |  Print  |  Notify Moderator

when we transfer from shore to genny in my 2005 sportscoach the GFI outlet in bathroom has to be reset sometime. this takes out oue front tv,micromave and one 120v outlet for what its worth. good luck.

camperfamily

New Jersey

Senior Member

Joined: 03/03/2008

View Profile





Offline
Posted: 08/06/13 08:13pm Link  |  Quote  |  Print  |  Notify Moderator

If your saying your getting 60 VOLTS from the gen (not 60 HZ - different) then you need to either get the gen repaired or if able repair it yourself. Could be a bad winding in the gen head or some other things.


2007 Pilgrim 278BHSS
2013 F350 CC LB 6.7
2002 F350 CC LB PS (Retired)
B&W Companion Hitch

THE-RV-MAN

Las Vegas

Full Member

Joined: 06/27/2010

View Profile



Good Sam RV Club Member

Offline
Posted: 08/07/13 04:11pm Link  |  Quote  |  Print  |  Notify Moderator

camperfamily wrote:

If your saying your getting 60 VOLTS from the gen (not 60 HZ - different) then you need to either get the gen repaired or if able repair it yourself. Could be a bad winding in the gen head or some other things.


What is a winding?

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 2  
Prev

Open Roads Forum  >  Class A Motorhomes  >  All

 > HELP!! Generator not turning on AC or microwave
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2017 CWI, Inc. © 2017 Good Sam Enterprises, LLC. All Rights Reserved. | Terms of Use | PRIVACY POLICY | YOUR PRIVACY RIGHTS